The intermittent issue that prevented users from accessing the full navigation on the web interface has been resolved. However, we will keep monitoring the platform to ensure stability. Thank you for your patience.
Posted Aug 21, 2025 - 13:37 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 21, 2025 - 13:06 UTC
Identified
The Zeta Marketing Platform is currently experiencing a partial disruption, preventing all users from accessing the full navigation on the web interface. Our team is actively investigating and working to restore functionality as soon as possible. The next update will be provided as soon as possible.
Posted Aug 21, 2025 - 13:03 UTC
Investigating
We have seen indication of a potential high severity issue with the Zeta Marketing Platform. We are actively working to identify the issue (impact and cause) and will update you with findings and confirmation of affected services once collected. Additional communications will be sent periodically with updates while we move through identification, impact analysis, and recovery. We value your trust and apologize for any inconvenience.
Posted Aug 21, 2025 - 12:57 UTC
This incident affected: Web Application and Custom Applications.