We’ve deployed a fix for the issue affecting campaigns. The engineering team is closely monitoring the system to confirm full resolution. Other platform services continue to operate normally.
Posted Jan 16, 2026 - 00:15 UTC
Identified
Further investigation shows that this issue is isolated to campaigns using internal feeds, not external feeds, as previously communicated. Our engineering team continues to work on a resolution and will provide additional updates as they become available. All other services remain operational. Thank you for your continued patience.
Posted Jan 16, 2026 - 00:14 UTC
Update
The Zeta Marketing Platform is currently experiencing an issue that may cause send failures for campaigns that use external feeds. Our engineering team is investigating and will provide updates as soon as more information is available. Other services remain operational. We appreciate your patience as we work to restore normal service.
Posted Jan 16, 2026 - 00:12 UTC
Investigating
We have seen indication of a potential high severity issue with the Zeta Marketing Platform. We are actively working to identify the issue (impact and cause) and will update you with findings and confirmation of affected services once collected. Additional communications will be sent periodically with updates while we move through identification, impact analysis, and recovery. We value your trust and apologize for any inconvenience.