The Zeta Marketing Platform web access outage

Resolved

The issue has been completely resolved.
Posted Jan 21, 2026 - 05:04 UTC

Monitoring

The web application has been restored and is now accessible. Our team is closely monitoring the platform to ensure continued stability and is continuing to investigate the root cause. All other services, including campaign deployments, APIs, and data imports/exports, remain fully operational. We will provide further updates as appropriate.
Posted Jan 21, 2026 - 04:39 UTC

Update

Our web application is currently down due to an outage. All other services, including campaign deployments, APIs, and data imports/exports, are fully operational. We're actively working on a fix and appreciate your patience. Updates will follow shortly.
Posted Jan 21, 2026 - 04:28 UTC

Investigating

We have seen indication of a potential high severity issue with the Zeta Marketing Platform. We are actively working to identify the issue (impact and cause) and will update you with findings and confirmation of affected services once collected. Additional communications will be sent periodically with updates while we move through identification, impact analysis, and recovery.
We value your trust and apologize for any inconvenience.
Posted Jan 21, 2026 - 04:11 UTC
This incident affected: Web Application.