This incident has been fully resolved. All services, including email delivery, HPM messaging, and the Events API, are operating normally. The backlog of queued messages has cleared, and there has been no data loss. We will continue to monitor system performance to ensure ongoing stability. Thank you for your patience.
Posted Jan 23, 2026 - 08:23 UTC
Update
Earlier today, we experienced temporary delays in outbound email delivery due to a widespread Microsoft service disruption that impacted a key part of our email sending infrastructure. The related impact on HPM messaging also led to the events API returning 502 errors intermittently. The external issue has since been resolved, and both email sending and events API have returned to normal operations. Messages that were queued during the disruption are now being processed and are expected to fully clear within the next 4–6 hours. There has been no data loss, and our teams are actively monitoring the system to ensure continued stability.
Posted Jan 23, 2026 - 05:36 UTC
Monitoring
Earlier today, we experienced temporary delays in outbound email delivery due to a widespread Microsoft service disruption that impacted a key part of our email sending infrastructure. The external issue has since been resolved, and email sending has returned to normal operations.Messages that were queued during the disruption are now being processed and are expected to fully clear within the next 4–6 hours. There has been no data loss, and our teams are actively monitoring the system to ensure continued stability.
Posted Jan 23, 2026 - 04:09 UTC
Update
The Zeta Marketing Platform is experiencing a performance degradation in the sending infrastructure, resulting in some campaigns experiencing sending delays. Our engineering team is actively investigating and working to restore normal sending performance as quickly as possible. There is no data loss. We apologize for the inconvenience and will provide updates as more information becomes available.
Posted Jan 23, 2026 - 02:54 UTC
Update
The Zeta Marketing Platform is experiencing a performance degradation in the sending infrastructure, resulting in some campaigns failing to send. Our engineering team is actively investigating and working to resolve the issue as quickly as possible. We apologize for the inconvenience and will provide updates as soon as more information becomes available.
Posted Jan 23, 2026 - 01:17 UTC
Investigating
The Zeta Marketing Platform is experiencing performance degradation on the email dispatcher, causing some of the campaigns not being sent. All other services are fully operational. We are actively investigating the issue. We appreciate your patience. Updates will follow shortly.
Posted Jan 23, 2026 - 00:40 UTC
This incident affected: API (Events API) and Platform (Campaigns).