Custom Applications performance degradation

Resolved

The issue has been remediated.
Posted May 02, 2025 - 16:11 UTC

Investigating

We are investigating a performance degradation in the custom application environment
Posted May 02, 2025 - 15:45 UTC
This incident affected: Custom Applications.