All systems are now performing as expected, and backlogs have been cleared. This incident is now fully resolved. We will continue to monitor to ensure ongoing stability.
Thank you for your patience while we worked to restore full functionality.
Posted Nov 18, 2025 - 10:32 UTC
Monitoring
All non-system (end-user) events have been fully processed, and end-user functionality is operating normally. The remaining backlog is limited to system events only, which do not impact core business workflows. Processing is progressing as expected, and we continue to actively monitor until full clearance.
Posted Nov 18, 2025 - 06:30 UTC
Update
We are currently still processing the backlog to restore normal performance, with continued monitoring in place to ensure stability. We appreciate your patience as we work to fully resolve this issue.
Posted Nov 18, 2025 - 04:45 UTC
Update
Our engineering teams have identified the root cause and deployed a fix. We are currently processing the backlog to restore normal performance, and updates in the UI should progressively return to expected levels over the next few hours. Thank you for your continued patience as we complete this work.
Posted Nov 18, 2025 - 02:57 UTC
Identified
Our engineering teams have identified a potential root cause and are actively working on a fix. We will provide updates as progress continues. We are currently observing slower-than-usual performance in our user interface, specifically within the Events tab in Experiences. All underlying event processing systems remain fully operational, and no data loss or processing delays have been detected. This issue is limited to the UI and may cause updates or metrics in the Events tab to appear with a temporary delay. The related API, https://docs.zetaglobal.com/reference/get-recent-events-for-a-person, is also impacted and may experience slower response times.
Posted Nov 18, 2025 - 02:23 UTC
Update
We are currently observing slower-than-usual performance in our user interface, specifically within the Events tab in Experiences. All underlying event processing systems remain fully operational, and no data loss or processing delays have been detected. This issue is limited to the UI and may cause updates or metrics in the Events tab to appear with a temporary delay. The related API, https://docs.zetaglobal.com/reference/get-recent-events-for-a-person, is also impacted and may experience slower response times. Our engineering teams are actively working to restore normal performance, and we expect resolution within the next few hours. Thank you for your patience as we complete this work.
Posted Nov 18, 2025 - 00:35 UTC
Investigating
We have seen indication of a potential high severity issue with the Zeta Marketing Platform. We are actively working to identify the issue (impact and cause) and will update you with findings and confirmation of affected services once collected. Additional communications will be sent periodically with updates while we move through identification, impact analysis, and recovery. We value your trust and apologize for any inconvenience.